한국어 English Chinese Russian
Support

Q&A



Your information is protected by SSL.
No. 1700 Re: Re: SMG-5420 - No Signals via Modbus RTU 2019-11-13

Works! Thank you for your fast response.

Benjamin Beck


> Sollae Systems wrote:
> ------------------------------------
> Dear Benjamin Beck,
>
> SMG-5420 device receives Modbus/TCP frame from TCP, converts it to Modbus RTU/ASCII frame and sends it to the serial port, and vice versa.
>
> Seemingly, the date frame you sent via TCP is the Modbus RTU frame, NOT Modbus/TCP frame. Therefore, It does NOT work.
>
> You can refer to Mobus/TCP frame in this document https://www.eztcp.com/en/download/pds_files/an_modbus_tcp_en.pdf
>
> We recommend you to use a Modbus Tool for testing instead of sending raw data for testing.
>
> For more information about configuring SMG-5420, you can refer to this FAQ: https://www.eztcp.com/en/support/view.php?page=1&cid=484
>
> If the problem is not solved, could you please send us via email (support@eztcp.com) the following information:
> - The screenshot of SMG-5420's setting
> - Modbus configuration of your control unit
>
> And, is your network topology similar to the scheme in this image https://www.eztcp.com/en/support/images/case1.png ?
>
>
>
>
> > Benjamin Beck wrote:
> > ------------------------------------
> > Dear Madams and Sirs,
> >
> > I am trying to connect a SMG-5420 device to control unit via ModbusRTU (RS485). Seemingly, the SMG does not recognize any Signals on TX and RX. I am using the following configuration
> >
> > Bd-rate: 9600 bps
> > Data bits: 8
> > Stop bits: 2
> > Parity: None
> > SMG working as TCP Server
> > Port 502
> > Connection Timeout 60s
> > Query Flow: TCP to Serial
> > Slave ID 0
> > Response Time: 500 ms
> > Send Gateway Exception: Disable
> >
> > When I try to access the Modbus via EzTerm (or similar tools) and try to send
> >
> > 15 04 00 02 00 01 93 1E
> >
> > The connection is terminated.
> >
> > Trying to emulate a Com-Port via ezVSP didn't either.
> >
> > Is a 120 Ohm resistor necessary for proper signal termination? What might be the reason for the Modbus Connection problems?
> >
> > Best regards,
> >
> > Benjamin Beck
> >
> >
> >

Writer Benjamin Beck Company Nemak